$re = '/^b{4}[0-9a-f]{28}$/';
$str = 'bbbb00000000000000170d0000306fb6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);