using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w]{8}\s+(INFO|WARN|ERROR)\s+\d\d:\d\d:\d\d\.\d\d\d";
string input = @"pdlvkw6v INFO 18:25:03.994 pdlvkw6v WARN 18:25:03.994 pdlvkw6v INFO 18:25:03.994 rg9n9bz7 INFO 18:23:52.987 rg9n9bz7 ERROR 19:23:52.987
rg9n9bz7 INFO 21:23:52.987 5y6n9bz7 WARN 18:23:52.987 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}