package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w]{8}\s+(INFO|WARN|ERROR)\s+\d\d:\d\d:\d\d\.\d\d\d`)
var str = `pdlvkw6v INFO 18:25:03.994 pdlvkw6v WARN 18:25:03.994 pdlvkw6v INFO 18:25:03.994 rg9n9bz7 INFO 18:23:52.987 rg9n9bz7 ERROR 19:23:52.987
rg9n9bz7 INFO 21:23:52.987 5y6n9bz7 WARN 18:23:52.987 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}