$re = '/message\=\"abtest platform\=\\\\\"(?P<abtest_platform>[^\\\\]*)\\\\\",\s*\[testName\=\\\\\"(?P<testName>[^\\\\]*)\\\\\",testId\=\\\\\"(?P<testId>[^,]*),\\\\\",experience\=\\\\\"(?P<experience>[^\\\\]*)/m';
$str = 'message="abtest platform=\\"Target\\", [testName=\\"test1\\",testId=\\"253041,\\",experience=\\"lefNavigation\\"]"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);