import Foundation
let pattern = #"message\=\"abtest platform\=\\\"(?P<abtest_platform>[^\\]*)\\\",\s*\[testName\=\\\"(?P<testName>[^\\]*)\\\",testId\=\\\"(?P<testId>[^,]*),\\\",experience\=\\\"(?P<experience>[^\\]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"message="abtest platform=\"Target\", [testName=\"test1\",testId=\"253041,\",experience=\"lefNavigation\"]""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)