import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\?(?:\\(\\w{1,3}\\))?(?: \\d+\\?(?:\\(\\w{1,3}\\))?)+";
final String string = "3A 4?(1) 5?(2) 6?(a) 7?(4) 8?(a) 9?(ii) 10?\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}