$re = '/\d+\?(?:\(\w{1,3}\))?(?: \d+\?(?:\(\w{1,3}\))?)+/m';
$str = '3A 4?(1) 5?(2) 6?(a) 7?(4) 8?(a) 9?(ii) 10?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);