#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)_2020\d{4}_|\."
Local $sString = "_20201007144100_20200416_reg.zip" & @CRLF & _
"" & @CRLF & _
"_20201007103200_20201007.zip" & @CRLF & _
"" & @CRLF & _
"_20201007095000_20201007.zip" & @CRLF & _
"" & @CRLF & _
"_20201007092933_20201007.zip" & @CRLF & _
"" & @CRLF & _
"_20201007061717_20201007_txn.zip" & @CRLF & _
"" & @CRLF & _
"_20201007041719_20201007.zip"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")