import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_2020\\d{4}_|\\.";
final String string = "_20201007144100_20200416_reg.zip\n\n"
+ "_20201007103200_20201007.zip\n\n"
+ "_20201007095000_20201007.zip\n\n"
+ "_20201007092933_20201007.zip\n\n"
+ "_20201007061717_20201007_txn.zip\n\n"
+ "_20201007041719_20201007.zip";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}