import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(idMatches):\\n(?s)(.+?)(Close: )(?s)(.+?)$";
final String string = "<ENG6_6701>\n"
+ "idMatches:\n\n"
+ "Close: ENG6_6701\n\n"
+ "<ENG6_7211>\n"
+ "idMatches:\n\n"
+ "Close: ENG6_7211\n\n"
+ "<ENG6_4474>\n"
+ "idMatches:\n"
+ "04\\B\\_3\\IFM_2017.30_App.CrashMonitor.CrashMonitor:11098: <testcase name=\"SysRS_3104_row 1\" type=\"1\" id=\"11177\" foreign_id=\"0\" testdata_id=\"1073741963\" state_mask=\"0x1100\" testcase_number=\"8\" child_count=\"1\" description=\"ENG6_4474\" specification=\"\" comment=\"\" uuid=\"c0a39548-d902-4a76-b986-3f0c49e7f8b1\" testitem_state_mask=\"0x80\" usercode_state_mask=\"0x00\" last_modified=\"1587729309934\" last_synchronized=\"0\">\n"
+ "04\\B\\_3\\IFM_2017.30_App.CrashMonitor.CrashMonitor.tmb:11098: <testcase name=\"SysRS_3104_row 1\" type=\"1\" id=\"11177\" foreign_id=\"0\" testdata_id=\"1073741963\" state_mask=\"0x1100\" testcase_number=\"8\" child_count=\"1\" description=\"ENG6_4474\" specification=\"\" comment=\"\" uuid=\"c0a39548-d902-4a76-b986-3f0c49e7f8b1\" testitem_state_mask=\"0x80\" usercode_state_mask=\"0x00\" last_modified=\"1587729309934\" last_synchronized=\"0\">\n"
+ "04\\G\\0\\IFM_2017.30_App.CrashMonitor.CrashMonitor.CrashMonitor_Main.script:645: ENG6_4474\n"
+ "06\\05\\EE\\IFM_2017.30_App.CrashMonitor.CrashMonitor:10507: <testcase name=\"SysRS_3104_row 1\" type=\"1\" id=\"4573\" foreign_id=\"0\" testdata_id=\"1073741963\" state_mask=\"0x5B00\" testcase_number=\"37\" child_count=\"1\" description=\"ENG6_4474\" specification=\"\" comment=\"\" uuid=\"c0a39548-d902-4a76-b986-3f0c49e7f8b1\" testitem_state_mask=\"0x80\" usercode_state_mask=\"0x00\" last_modified=\"1587560383700\" last_synchronized=\"0\">\n"
+ "06\\10\\00\\Crasmonitor\\IFM_2017.30_App.CrashMonitor.CrashMonitor.CrashMonitor_Main.script:220: ENG6_4474\n\n"
+ "Close: ENG6_4474\n\n"
+ "<ENG6_4475>\n\n"
+ "NOTE: it was needed to change the first \\n for a \\r";
final String subst = "\\t<\\1>\\n\\t\\t\\2\\t</\\1>\\n</\\4>\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}