#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\*[A-Z]{3}:)"
Local $sString = "*TOB: hola estamos aquí porque hemos recibido cinco mil euros y tenemos que: decidir (.) qué hacemos con este dinero (.) yo propongo que con este dinero pagamos actividades para que: los estudiantes se conocen y para que aprenden cómo: formar una comunidad un equipo por eso propongo que: pagamos actividades como paintball lastertag o:: m:: a lo mejor una excursión a port aventura para que los estudiantes se pueden conocer y pueden: (.) crecer amis- amistades y tal ¿qué os parece?" & @CRLF & _
"*MIN: pue::s ¿de cuán dinero hablamos?" & @CRLF & _
"*PPP: (0.9)" & @CRLF & _
"*TOB: mh ¿perdón?="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")