use strict;
my $str = '*TOB: hola estamos aquí porque hemos recibido cinco mil euros y tenemos que: decidir (.) qué hacemos con este dinero (.) yo propongo que con este dinero pagamos actividades para que: los estudiantes se conocen y para que aprenden cómo: formar una comunidad un equipo por eso propongo que: pagamos actividades como paintball lastertag o:: m:: a lo mejor una excursión a port aventura para que los estudiantes se pueden conocer y pueden: (.) crecer amis- amistades y tal ¿qué os parece?
*MIN: pue::s ¿de cuán dinero hablamos?
*PPP: (0.9)
*TOB: mh ¿perdón?=';
my $regex = qr/(?<=\*[A-Z]{3}:)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}