import re
regex = re.compile(r"<text(.[^>]+)>\n(\s+)(.+)\n(.+)<\/text>")
test_str = ("<text class=\"wx-text_tz7UYs\" data-c_e_id=\"wx-textf2d09dd7377909fe\">\n"
" 测试动画:比例\n"
" </text>\n"
"<text class=\"wx-text_tz7UYs\" data-c_e_id=\"wx-textf2d09dd7377909fe\">\n"
" 测试动例\n"
" </text>")
subst = "<text ${1}>${3}</text>"
result = regex.sub(subst, test_str)
if result:
print(result)