use strict;
my $str = 'validandodominiopodesim@pode.sim
validandodominiopodenao@pode.nao
a@pode.sim
variasletras@pode.sim
ComMaiusculaS@pode.sim
0numeronocomeco@pode.nao
numeronofinal0@pode.sim
com0varios1numeros2@pode.sim
com-varios-hifens@pode.sim
-hifennocomeco@pode.nao
hifennofinal-@pode.nao
dois--hifens@pode.nao
com.varios.pontos@pode.sim
.pontonocomeco@pode.nao
pontonofinal.@pode.nao
dois..pontos@pode.nao
com_sublinhado@pode.nao
_sublinhadonocomeco@pode.nao
sublinhadonofinal_@pode.nao
com.ponto-e-hifen@pode.sim
com-hifen-e.ponto@pode.sim
mas.-seguidos@pode.nao
mas-.seguidos@pode.nao';
my $regex = qr/^[a-zA-Z]+([.-]?[a-zA-Z0-9])*@([\w-]+\.)+([A-Za-z]{2,4})+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}