$re = '/[\w"]+/m';
$str = 'dsf"dsf sdfd"asfd as ssd"f sa fsd f sdf"sd fsdf sdh"tyr ujytjf yugtkuh ykhujhjhj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);