re = /[\w"]+/m
str = 'dsf"dsf sdfd"asfd as ssd"f sa fsd f sdf"sd fsdf sdh"tyr ujytjf yugtkuh ykhujhjhj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end