# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^\W_]{3,8})-(?1)$"
test_str = ("Therefore for it to be valid some examples could be:\n\n"
"Text-Text\n"
"Abc-123\n"
"123-Abc\n"
"A2C-def4gk\n\n"
"Invalid tests could be:\n\n"
"Ab-3\n"
"Abc!-ajr4\n"
"a-bc3-25aj\n"
"a?c-b%\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.