re = /^([^\W_]{3,8})-(?1)$/m
str = 'Therefore for it to be valid some examples could be:
Text-Text
Abc-123
123-Abc
A2C-def4gk
Invalid tests could be:
Ab-3
Abc!-ajr4
a-bc3-25aj
a?c-b%
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end