import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\# ?\\d+\\.)";
final String string = "# This is a comment <-beacuse it starts at the begining of the file\n"
+ "# This is a comment <- see above\n"
+ "# 1. Item one <- not a comment because it starts with 1.\n"
+ "# Description of Item 1 <- not a comment as it is after a line that starts with a number\n"
+ "data point 1\n"
+ "data point 2\n"
+ "data point etc\n"
+ "3 <-- represents number of data points under Item one\n\n"
+ "# 2. Item two <-- not a comment\n"
+ "# Description of item 2 <-- not a comment\n"
+ "data point 1\n"
+ "data point ..\n"
+ "data point 100\n"
+ "100\n"
+ "#3. Item three <--- not a comment\n"
+ "# Item three description\n"
+ "0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}