package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{5}(?:-?\d{4})?`)
var str = `12345
12345-6789
123456789
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}