$re = '/\d{5}(?:-?\d{4})?/';
$str = '12345
12345-6789
123456789
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);