$re = '/[0-9]*(?:[0-9]{0,9}[^0-9]+)*(?:([0-9]{9,})|[0-9]*\z)/';
$str = '[JGMORGAN - BANK2] n° 10 NEWYORK, n° 222 CAEN, MONTELLIER, VANNES / TARARTA TIs 1303222074, 1403281851 & 1307239335 et Cloture TIs 1403277567, 1410315029
[SOCIETE - AUTRE] N76 - PORT \\ Mot Test N°1409307426 \\Perte de visu de la borne02';
$subst = "\1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;