$re = '/^(\$?[0-9]+(?>,[0-9]{3})*(?>\.[0-9]{2})?(?(1)\))$/m';
$str = '$1,024.12
15683.33
$15,683.33
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);