#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(^\s*'(.)*'\s*$)"
Local $sString = "'This is a test'" & @CRLF & _
"" & @CRLF & _
"This is a Test" & @CRLF & _
"" & @CRLF & _
"not supported" & @CRLF & _
"This is a ''Test'' Nice" & @CRLF & _
"" & @CRLF & _
"'This is a test ''Nice'' nice'" & @CRLF & _
"" & @CRLF & _
"This is a ''Test'' Nice"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")