import re
regex = re.compile(r"(^\s*'(.)*'\s*$)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("'This is a test'\n\n"
"This is a Test\n\n"
"not supported\n"
"This is a ''Test'' Nice\n\n"
"'This is a test ''Nice'' nice'\n\n"
"This is a ''Test'' Nice")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")