$re = '/\b(?:([123456])(?![123456789]*\1))+\b/m';
$str = '123456
122456
123465
653214
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);