re = /\b(?:([123456])(?![123456789]*\1))+\b/m
str = '123456
122456
123465
653214
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end