$re = '/\*\*(.+?)\*\*/m';
$str = 'abc ** this is * matching ** but not this ** and this is a new one ** def';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);