re = /\*\*(.+?)\*\*/m
str = 'abc ** this is * matching ** but not this ** and this is a new one ** def'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end