using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+\s)worksheets\/([a-z]+)?\/?(\d+)\/\d+";
string input = @"Viewed worksheets/get/4/115
Viewed worksheets/4/115
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}