re = /(\S+\s)worksheets\/([a-z]+)?\/?(\d+)\/\d+/m
str = 'Viewed worksheets/get/4/115
Viewed worksheets/4/115
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end