package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<q_num>\d{1,3})\)\s?(?P<quest>.+)\n(\s?a\)\s?)(?P<ans_a>.+)(b\)\s?)(?P<ans_b>.+)((c\)\s?)(?P<ans_c>.+))?((d\)\s?)(?P<ans_d>.+))?`)
var str = `1) First question with 4 choices ?
a) First choice b) Second choice c) Third choice d) Last choice
2) Second question with only 3 choices ?
a) First choice b) Second choice c) Last choice
3) True or False ?
a) True b) False`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}