const regex = /(?P<q_num>\d{1,3})\)\s?(?P<quest>.+)\n(\s?a\)\s?)(?P<ans_a>.+)(b\)\s?)(?P<ans_b>.+)((c\)\s?)(?P<ans_c>.+))?((d\)\s?)(?P<ans_d>.+))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<q_num>\\d{1,3})\\)\\s?(?P<quest>.+)\\n(\\s?a\\)\\s?)(?P<ans_a>.+)(b\\)\\s?)(?P<ans_b>.+)((c\\)\\s?)(?P<ans_c>.+))?((d\\)\\s?)(?P<ans_d>.+))?', 'g')
const str = `1) First question with 4 choices ?
a) First choice b) Second choice c) Third choice d) Last choice
2) Second question with only 3 choices ?
a) First choice b) Second choice c) Last choice
3) True or False ?
a) True b) False`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}