#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?P<q_num>\d{1,3})\)\s?(?P<quest>.+)\n" & @CRLF & _
"" & @CRLF & _
"(\s?a\)\s?)(?P<ans_a>(?:(?![a-d]\)).)+)" & @CRLF & _
" (b\)\s?)(?P<ans_b>(?:(?![a-d]\)).)+)" & @CRLF & _
" ((c\)\s?)(?P<ans_c>(?:(?![a-d]\)).)+))?" & @CRLF & _
" ((d\)\s?)(?P<ans_d>(?:(?![a-d]\)).)+))?"
Local $sString = "1) First question with 4 choices ?" & @CRLF & _
"a) First choice b) Second choice c) Third choice d) Last choice" & @CRLF & _
"2) Second question with only 3 choices ? " & @CRLF & _
"a) First choice b) Second choice c) Last choice" & @CRLF & _
"3) True or False ? " & @CRLF & _
"a) True b) False"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")