import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<q_num>\\d{1,3})\\)\\s?(?P<quest>.+)\\n\n\n"
+ "(\\s?a\\)\\s?)(?P<ans_a>(?:(?![a-d]\\)).)+)\n"
+ " (b\\)\\s?)(?P<ans_b>(?:(?![a-d]\\)).)+)\n"
+ " ((c\\)\\s?)(?P<ans_c>(?:(?![a-d]\\)).)+))?\n"
+ " ((d\\)\\s?)(?P<ans_d>(?:(?![a-d]\\)).)+))?";
final String string = "1) First question with 4 choices ?\n"
+ "a) First choice b) Second choice c) Third choice d) Last choice\n"
+ "2) Second question with only 3 choices ? \n"
+ "a) First choice b) Second choice c) Last choice\n"
+ "3) True or False ? \n"
+ "a) True b) False";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}