using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (\S+ *)$";
string substitution = @",\1";
string input = @"Bob Jane";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}