package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) (\S+ *)$`)
var str = `Bob Jane`
var substitution = ",\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}