re = /[\w]/i
str = 'ийская, д. 35, кв. 9 Показано с 1 по 1 (Всего: 1) Перейти к разделу Сообщения Включение сведенийё'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end