import re
regex = re.compile(r"^(?:(>.*?$)(.*?)(?=^>|\Z))", flags=re.MULTILINE | re.DOTALL)
test_str = ("> header, info, info\n"
"TEXT----------------------------------------------------------------\n"
"TEXT2-------------------------------------------\n"
">header, info...\n"
"TEXT-----------------------------------------------------")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")