using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\n*.*+)+\1<tr>\n.*<td bgcolor=\""#ffffcc\"">";
string input = @"
<tr>
<td bgcolor=""#ffffcc"">
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}