$re = '/(\n*.*+)+\1<tr>\n.*<td bgcolor=\"#ffffcc\">/';
$str = '
<tr>
<td bgcolor="#ffffcc">
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);