const regex = /(([A-Z][a-z]+)\s{0,2}([A-Z][a-z]+)?\s{0,2}([A-Z][a-z]+)?)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([A-Z][a-z]+)\\s{0,2}([A-Z][a-z]+)?\\s{0,2}([A-Z][a-z]+)?)', '')
const str = `Russell Lake West`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}