#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\[\[(.+?)\]\]"
Local $sString = "moment.tz("[[YYYY+JIT60]]-[[MMM+JIT60]]-[[DD+JIT60]] [[time2+JIT60]]", "America/New_York");" & @CRLF & _
"<ul style='margin: 1em 0 0;' class='countdown' data-timestamp='[[timestamp JIT60]]000'><li>" & @CRLF & _
"" & @CRLF & _
"Thanks to http://stackoverflow.com/a/6705862/470749!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")