$re = '/\[\[(.+?)\]\]/im';
$str = 'moment.tz("[[YYYY+JIT60]]-[[MMM+JIT60]]-[[DD+JIT60]] [[time2+JIT60]]", "America/New_York");
<ul style=\'margin: 1em 0 0;\' class=\'countdown\' data-timestamp=\'[[timestamp JIT60]]000\'><li>
Thanks to http://stackoverflow.com/a/6705862/470749!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);