import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^&|\"](#[0-9]+\\b)(?!<\\/a>)";
final String string = "Test 1: j\n"
+ "Test 2: #1040\n"
+ "Test 3: some text followed by #1060\n"
+ "Test 4: <a href=\"#1060\">#1060</a>\n"
+ "Test 5: <b>#1078</b> (...or any other tag except <a>)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}