const regex = /[^&|"](#[0-9]+\b)(?!<\/a>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^&|"](#[0-9]+\\b)(?!<\\\/a>)', 'g')
const str = `Test 1: j
Test 2: #1040
Test 3: some text followed by #1060
Test 4: <a href="#1060">#1060</a>
Test 5: <b>#1078</b> (...or any other tag except <a>)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}