const regex = /^[A-Za-z]+[A-Za-z0-9]*(?:[-][A-Za-z0-9]+)*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z]+[A-Za-z0-9]*(?:[-][A-Za-z0-9]+)*$', '')
const str = `sdf-asdfe22-ww-2dsdfas-df
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}