$re = '/^[A-Za-z]+[A-Za-z0-9]*(?:[-][A-Za-z0-9]+)*$/';
$str = 'sdf-asdfe22-ww-2dsdfas-df
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);