#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-5][0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-5][0-5])"
Local $sString = "255.0.0.1" & @CRLF & _
"127.0.0.1" & @CRLF & _
"127,0,0,1" & @CRLF & _
"192.168.178.90" & @CRLF & _
"89.50.50.123" & @CRLF & _
"0000.2.2.2" & @CRLF & _
"2.0000.2.2" & @CRLF & _
"2.2.0000.2" & @CRLF & _
"2.2.2.0000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")