using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-5][0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9][0-9]|2[0-5][0-5])";
string input = @"255.0.0.1
127.0.0.1
127,0,0,1
192.168.178.90
89.50.50.123
0000.2.2.2
2.0000.2.2
2.2.0000.2
2.2.2.0000";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}